First things first to all of the SolidCP developers and contributors – a huge thumbs up and thank you for keeping the open source edition alive and well.

Since the upgrade to SolidCP 1.4.3 we are having problems with new DNS Zones that are created for Simple DNS 8 (Build 107). Editing of the zones is working fine so this is just a problem with new ones. When we upgraded to 1.4.3 from 1.4.2 we edited the SolidCP database and changed the SimpleDNS Provider to v8.x for our DNS Service. So far so good, we could edit zones although we now had to add a full stop at the end of the record but thats OK it at least works but when we create a new zone by adding a domain the zone file gets a bit messed up and you can see from the screenshot below.

Maybe this is caused by our setup of DNS server in SolidCP (which incidentally has not changed since it was setup in DotNetPanel) but basically we only have the 1 DNS Server configured in SolidCP as SimpleDNS takes care of creating and maintaining the zones on our secondary server.

We have defined the Primary and Secondary servers in SolidCP as you can see from the screenshot below but when the zone is created it takes these records and adds the users domain after each NS record and then adds another NS record for good measure for some reason. I tried adding a full stop to the end of the Primary and Secondary servers, by using the database as the portal would not allow it, but that did not work either and resulted in neither of the NS records being added.  I also tried the information in this link but it did not have any effect https://solidcp.com/forum/question/how-to-setup-solidcp-with-a-simpledns-v6-cluster/

SimpleDNS Plus 8.x Provider Setup showing our Primary and Secondary servers are defined

This is how the zone gets created

Is this a known bug or is there something else we need to configure for 1.4.3?

Mark Donne

Answered question