0

I successfully upgrade the Installer from 1.3 to 1.4 and double checked the .config, it has all 3 of the 1.3 components listed as expected (from key=”Installer” value=”SolidCP-StandaloneServerSetup.zip”). So I assume I should start with the Enterprise Server and click on it under Components inthe Installer UI. It shows the existing/working 1.3 install. I can go to (on the server) http://127.0.0.1:9002 and I see the Status: Running, Version: 1.3.0. So I click the Check for Updates button. It displays a popup, “Enterprise Server 1.40 is available…” and I answer Yes. It starts to download and launch, the installation starts, gets through a few steps and then I get a .Net error, click through twice and the installer has crashed and closes. I go to the LOG file and find this at the end.

This leaves the install in a failed state, cannot login to the CP portal. I can get running again by restoring the files to C:SolidCPEnterprise Server from a backup. Anyone have an idea as to how/why I am getting this access denied error on a DLL? It appears to be successfully stopping the app pool.

[3/11/2018 4:25:07 PM] INFO: IIS 10.0 detected
[3/11/2018 4:25:07 PM] START: Loading application configuration
[3/11/2018 4:25:07 PM] END: Application configuration loaded
[3/11/2018 4:25:07 PM] START: Checking for a new version
[3/11/2018 4:25:08 PM] END: Checked for a new version
[3/11/2018 4:25:08 PM] START: Loading installed components
[3/11/2018 4:25:08 PM] END: 3 installed component(s) loaded
[3/11/2018 4:25:13 PM] START: Checking for component update
[3/11/2018 4:25:13 PM] INFO: Checking Enterprise Server 1.3.0
[3/11/2018 4:25:14 PM] END: Component update checked
[3/11/2018 4:25:14 PM] INFO: Version 1.4.0 is available for download
[3/11/2018 4:25:18 PM] START: Updating component
[3/11/2018 4:25:18 PM] INFO: Updating Enterprise Server
[3/11/2018 4:25:18 PM] INFO: Tmp directory created
[3/11/2018 4:25:18 PM] START: Downloading file
[3/11/2018 4:25:18 PM] INFO: Downloading file “~/Files/1.4.0/SolidCP-EnterpriseServer-Update.zip” to “C:Program Files (x86)SolidCP InstallerTmpSolidCP-EnterpriseServer-Update.zip”
[3/11/2018 4:25:22 PM] END: Downloaded 1882690 bytes
[3/11/2018 4:25:22 PM] START: Unzipping file
[3/11/2018 4:25:22 PM] INFO: Unzipping file “C:Program Files (x86)SolidCP InstallerDataSolidCP-EnterpriseServer-Update.zip” to the folder “C:Program Files (x86)SolidCP InstallerTmp”
[3/11/2018 4:25:22 PM] END: Unzipped file
[3/11/2018 4:25:22 PM] START: Running installer SolidCP.Setup.EnterpriseServer140.Update from setupsetup.dll
[3/11/2018 4:25:23 PM] INFO: Setup wizard loaded.
[3/11/2018 4:25:23 PM] INFO: IntroductionPage loaded.
[3/11/2018 4:25:30 PM] INFO: LicenseAgreementPage loaded.
[3/11/2018 4:25:31 PM] INFO: ExpressInstallPage loaded.
[3/11/2018 4:25:31 PM] START: Stopping IIS Application Pool
[3/11/2018 4:25:31 PM] INFO: Stopping “SolidCP Enterprise Server Pool”
[3/11/2018 4:25:31 PM] END: Stopped IIS Application Pool
[3/11/2018 4:25:31 PM] START: Creating backup directory
[3/11/2018 4:25:31 PM] END: Created backup directory
[3/11/2018 4:25:31 PM] START: Backing up database “SolidCP”
[3/11/2018 4:25:32 PM] END: Backed up database
[3/11/2018 4:25:32 PM] START: Creating directory C:Program Files (x86)SolidCP InstallerBackup2018-03-11SolidCP Enterprise Server 1.3.0App
[3/11/2018 4:25:32 PM] END: Created directory
[3/11/2018 4:25:32 PM] START: Backing up files
[3/11/2018 4:25:32 PM] INFO: Zipping files from “C:SolidCPEnterprise Server” to “C:Program Files (x86)SolidCP InstallerBackup2018-03-11SolidCP Enterprise Server 1.3.0Appapp.zip”
[3/11/2018 4:25:34 PM] END: Backed up files
[3/11/2018 4:25:34 PM] START: Backing up system configuration
[3/11/2018 4:25:34 PM] START: Creating directory C:Program Files (x86)SolidCP InstallerBackup2018-03-11SolidCP Enterprise Server 1.3.0Config
[3/11/2018 4:25:34 PM] END: Created directory
[3/11/2018 4:25:34 PM] END: Backed up system configuration
[3/11/2018 4:25:34 PM] START: Deleting files
[3/11/2018 4:25:37 PM] ERROR: File delete error
System.UnauthorizedAccessException: Access to the path ‘C:SolidCPEnterprise ServerbinSolidCP.EnterpriseServer.Base.dll’ is denied.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileInfo.Delete()
at SolidCP.Setup.FileUtils.DeleteFileInternal(String fileName)
at SolidCP.Setup.FileUtils.DeleteFile(String fileName)
at SolidCP.Setup.FileUtils.DeleteDirectory(String directory)
at SolidCP.Setup.ExpressInstallPage.DeleteFiles(String file)
[3/11/2018 4:25:52 PM] INFO: RollBackPage loaded.
[3/11/2018 4:25:52 PM] START: Rolling back
[3/11/2018 4:25:53 PM] INFO: Setup wizard was canceled by user
[3/11/2018 4:25:53 PM] INFO: Setup wizard was canceled by user
[3/11/2018 4:25:53 PM] INFO: Setup wizard closed.
[3/11/2018 4:25:53 PM] INFO: Setup wizard was canceled by user

Asked question