0

Hello, I’m a newbie with solidcp but i’m an old websitepanel user. I installed SolidCP and looks everything done. But when i try to install wordpress I faced some problems.

First I got database creation error and I tried to create database manually on SolidCP Panel. Then I tried again to install wordpress and this time I got this error:

– ApplicationInstallationError
– PackageInstallationError:Object reference not set to an instance of an object.; at SolidCP.Server.Code.WpiHelper.InstallApplication(String appId, List`1 updatedValues, String languageId, EventHandler`1 installStatusUpdatedHandler, EventHandler`1 installCompleteHandler, String& log, String& failedMessage) at SolidCP.Providers.Web.WPIWebApplicationGallery.WPIApplicationGallery.InstallApplication(Int32 UserId, String webAppId, List`1 updatedParameters, String languageId, StringResultObject& result) at SolidCP.Providers.Web.IIs60.InstallGalleryApplication(Int32 UserId, String webAppId, List`1 updatedValues, String languageId)

My server: Windows Server 2016, MySQL 5.7.17, I installed required dependencies before try to install wp.

After this error I tried to open website directly and wordpress installation page opened. I selected language, filled form for created wp admin user and now website is working well.

Is there anyone could tell me why I’m getting this error while installing wordpress to a website? Why I couldnt create database directly from install page? Thank you for your answers..