0

Now i have a working solution so maybe this will help someone.

I had some problem before with Awstat 400 and i couldnt solve it. i was trying to install that on one of my webservers.

Now i have install it like this on my portal server, probably you dont need to make any modification in the install script, but i did not want to have some things that the script is installing

So this is how i make it work.

Install Awstats.

Download http://installer.solidcp.com/Files/1.1.2/Tools/SolidCP-Configuration-Tool.zip

Unpack and I made a mod on the script
And it was complaining about ROW 4737 that it couldnt find the download path.
So i change it to this.

(New-Object System.Net.WebClient).DownloadFile(“http://installer.solidcp.com/Files/stable/Tools/SolidCP-AWStatsViewer.zip”, “C:_Install Files$($AwStats_WebApp.FolderName)SolidCP-AWStatsViewer-$dSolidCPversion.zip”)

And i changed under ROW 625 Main menu Option 5 so i only have this

#####################
Function MainMenu_Option_5() { # Function to call multiple functions to install AwStats
CheckSolidCPdomainUser “Server”
dCheckIPaddressesSet
CLS
Write-Host “`n`n`n`n`n`n`n`n”  # This brings the text down by 8 lines to allow fo the Windows Features installation overlay
Write-Host “Installing the ‘AwStats Server'” -ForegroundColor Magenta
Write-Host “`tStarting server setup for SolidCP`n” -ForegroundColor Gray
InstallAwStats
HardenDotNETforIIS
InstallActivePerl
InstallDisablePasswdComplex
dPressAnyKeyToExit

####################################

I dont see a point were it should install all the other stuff on a server that dont need PHP and Python etc its just make it more open for bad things to happen.

After the script has install all the files, it didnt add my Enterprise server even if i typed it in.

So in web.config file i added that like this.
<add key=”AWStats.SolidCPAuthenticationProvider.EnterpriseServer” value=”http://My IP to Enterprise server:9002″ />

Then after install i go in to

Configuration /Servers /settings on the server i have install awstats
Add Statistics

I made some changes because this is a 64 bit server (Win 2016) it install Perl64

So
Batch File Line Template:    its %SYSTEMDRIVE%perl64binperl.exe awstats.pl config=[DOMAIN_NAME] -update

The log format on Win 2016 is u_ex so i change that in configuration template.

LogFile = “[LOGS_FOLDER]u_ex%YY-3%MM-3%DD-3.log”

I enable UNC Path (my statistic server is on another server than webservers so it can get the log files)

add your domainname go to IIS under SolidCP AwStats what name it should listen to so i change the url to.

http://stat.mydomain.com/cgi-bin/awstats.pl?config=[domain_name]

And then add statistic under your virtuall server then hostingplan.

 

Regards

 

Pelle