AWstats (401) Unaut...
Clear all

AWstats (401) Unauthorized

16 Posts
5 Users
0 Reactions
20 K Views
Posts: 40
Topic starter
Eminent Member
Joined: 8 years ago


I dont realy want to setup a win 2012 server, im doing a multiserver setup with all the newest software/OS and win 2016 support Http/2 and having just a 2012 server for Awstat is little overkill for me right now.

But im looking forward to your answer after weekend!



Posts: 40
Topic starter
Eminent Member
Joined: 8 years ago


Same error
HTTP Error 401.3 - Unauthorized
You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server.
Detailed Error Information:




Error Code

Requested URL

Physical Path

Logon Method

Logon User

Posts: 40
Topic starter
Eminent Member
Joined: 8 years ago

This is my config file.

<?xml version="1.0" encoding="UTF-8"?>
<!-- AWStats Viewer Settings -->
<add key="AWStats.URL" value="/cgi-bin/" />
<add key="AWStats.Username" value="" />
<add key="AWStats.Password" value="" />
<!-- Messages -->
<add key="AWStats.Message.DomainNotFound" value="Advanced statistics is not enabled for the specified domain. Login to control panel, open 'My Resources -> Advanced Statistics' page and add a new statistics site." />
<add key="AWStats.Message.WrongUsername" value="Account with the specified username does not exist! Make sure you type correct Control Panel username/password." />
<add key="AWStats.Message.WrongPassword" value="Incorrect password has been specified!" />
<!-- Authentication provider -->
<add key="AWStats.AuthenticationProvider" value="SolidCP.AWStats.Viewer.SolidCPAuthenticationProvider, SolidCP.AWStats.Viewer" />
<!-- ConfigFileAuthenticationProvider settings -->
<add key="AWStats.ConfigFileAuthenticationProvider.DataFolder" value="c:AWStatsdata" />
<!-- SolidCPAuthenticationProvider settings -->
<add key="AWStats.SolidCPAuthenticationProvider.EnterpriseServer" value="http://192.XXX.XXX.1:9002" />
<compilation defaultLanguage="c#" debug="true" targetFramework="4.0" />
<customErrors mode="RemoteOnly" />
<authentication mode="Windows">
<forms name=".AWSTATSVIEWER" loginUrl="default.aspx" protection="All" timeout="30" path="/">
<allow users="*" />
<!-- Allow all users -->
<pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID" /></system.web>
<windowsAuthentication enabled="true" />

Posts: 1965
Noble Member
Joined: 9 years ago

Well with that error i would check 2 things:

  1. i see you got windows auth enabled - You can't (or shouldn't) really have that together with anonymous auth (so normally you leave it disabled)
  2. your anonymous auth: what username does it use? and does that user have permissions to your directory? (if it uses application pool identity --> check the application pool user)

As the error generally just indicates a lack of permission of the user IIS is using.

Posts: 40
Topic starter
Eminent Member
Joined: 8 years ago
  1. I have turned that off.

Your script is setting IUSR but that dosent work. (Even if that user have permission in folder)

If i put user application pool identity and add this user full control on the whole mapp c:AWStats

Same result. 401

There is a application pool user SolidCP Awstats .NET v4 (from script)

That Application pool Identity is the same result 401

If i set the user Administrator then i can klick from inside SolidCP and view statistic (This is probably it dosent even try to login to solidcp) but i cant login if i going to the default startpage of Awstats with doman, user , password.(If i write something wrong then it says so, but if its correct its just like a reload off page)

This is some other things that wasent correct from standard installation

Your script is installing Perl64 and the catalog is c:Perl64 insted of just c:Perl

And i have changed that in SolidCP.

And another thing is that the log files of IIS is starting with u_ex and not ex

I have change that to.

And Statistics Help URL: i have removed "/Awstat" catalog so now its pointing like this[domain_name]

Well im total stuck here with 401.

Page 2 / 3