Forum

AWstats (401) Unaut...
 
Notifications
Clear all

AWstats (401) Unauthorized

Page 3 / 3

DatatechUK
Posts: 32
Moderator
(@datatechuk)
Member
Joined: 5 years ago

Hi,

I have spun up a Server 2016 Virtal Machine and all looks fine, but i have noticed that 2 values were not set in theweb.config file.

Culd you open the C:AWStatswwwrootweb.config file and change the following nodes:-
<add key="AWStats.ConfigFileAuthenticationProvider.DataFolder" value="~/cgi-bin"/>

<add key="AWStats.SolidCPAuthenticationProvider.EnterpriseServer" value="http://localhost/EnterpriseServer"/>

 

The DataFolder needs to be C:/AWStats/data   - (Replace the ForwardSlash with BackSlash)
The EnterpriseServer needs to be the URL of your Enterprise Server (including port), I.E. this would be something like http://192.168.0.1:9002

 

Please try the above and let me know hw you get on as i have just written this into the latest version of the script which i will be releasing tomorrow after some more testing.

Kind regards,
Marc

Reply
King-Dude
Posts: 40
Topic starter
(@king-dude)
Eminent Member
Joined: 5 years ago

Hi, Datatech.

I have change those settings in my config file but it seems not to be my problem.

(I have backslash, but this forum is removing it)

Can you tell me about your configuration.

Are you having only Anonomys access with user IUSR?

What catalogs in Awstat folder do that user have permisson to and type of permissions?

Are you running Perl64?

Regards

Pelle

Reply
1 Reply
DatatechUK
Moderator
(@datatechuk)
Joined: 5 years ago

Member
Posts: 32

Hi, I have finally started setting up our new enviroment using the Powerhell script that i have written and i can say that the new version of the script has setup AWstats perfectly and without any issues. Could you try downloading the latest version of the script and try setting up a new server. Just for reference, my AWstats server is joined tot he same domain as our Portal Server. Also please make sure you set the variables at the top of the script with your enviroment values. The Portal, Enterprise Server and Stats Server must be IPV4 addresses. Kind regards, Marc

Reply
King-Dude
Posts: 40
Topic starter
(@king-dude)
Eminent Member
Joined: 5 years ago
Reply
arshiasp
Posts: 7
(@arshiasp)
Active Member
Joined: 4 years ago

what was the method used to resolve this issue?

We have same problem and it's seems like we can't solve it. The funny part is we have 2 nodes and one is working while another isn't. It seems like both have same configuration.

Reply
yalxin28
Posts: 3
(@yalxin28)
New Member
Joined: 11 months ago

I have the same problem on Win 2019
Error while opening 'http://stat.domain/cgi-bin/awstats.pl?config=domain': The remote server returned an error: (404) Not Found.

windows auth= is Disable
App pool is ApplicationPoolIdentity

Removed Web-v2.0.conf from C:AWStats
Removed UpdateStats.bat from C:AWStats

On C:AWStatswwwrootweb.config <add key="AWStats.SolidCPAuthenticationProvider.EnterpriseServer" value="http://x.x.x.x:9002" />

DataFolder" value="C:AWStatsdata"

how can I solve this problem?

Reply
Page 3 / 3
Share:
Downloads