Let's Encrypt v1.4
 
Notifications
Clear all

Let's Encrypt v1.4

11 Posts
6 Users
0 Likes
2,036 Views
javier.wong
Posts: 73
Topic starter
(@javier-wong)
Trusted Member
Joined: 7 years ago

@Trevor, spot on, I had a http -> https redirector. Didn't expect it to cause this issue. But solved. Thank you.

Reply
Dolphyn5
Posts: 63
(@dolphyn5)
Trusted Member
Joined: 6 years ago

I think it helps to add something like the following to the system.webServer section of the LetsEncrypt Web_Config.xml file, and (if it doesn't cause problems) maybe this change could be made within the SolidCP installer.

<httpRedirect enabled="false" />
<rewrite>
<rules>
<clear />
</rules>
</rewrite>
<modules>
<remove name="Helicon.Ape" />
</modules>

Reply
jnitterauer
Posts: 18
(@jnitterauer)
Active Member
Joined: 4 years ago

I cannot get the certs to install either. My Event Logs show only this:

NullReferenceException: "Object reference not set to an instance of an object."

I see nothing else in the log

Reply
ubiquitas
Posts: 1
(@ubiquitas)
New Member
Joined: 4 years ago

I too have this problem. New certificates are fine but renewals fail with

NullReferenceException: Object reference not set to an instance of an object.

I do have SSL redirects in place, but have tried

  1. turning them off
  2. adding exception for the .well-known folder

Still the same. Additionally I'm noticing a system log error

A fatal error occurred while creating an SSL client credential. The internal error state is 10013.

We do have TLS1 disabled, along with insecure cyphers - wondering if that might be causing an issue??

Any pointers appreciated, got to get this sorted

Reply
indexebusiness
Posts: 35
(@indexebusiness)
Eminent Member
Joined: 6 years ago

We had this exact problem and we managed to find the cause of it for us. It turns out that if one of the scheduled certificate renewals is for a website that you no longer host it will not renew any other certificates. If you run the letsencrypt software from the command line

C:SolidCPServerbinLetsEncryptletsencrypt.exe

And then choose "L" to list the scheduled renewals and check that each website is still pointing at your server. You can generally tell which one is causing the problem if you run the renewal manually by choosing option "R" to Renew Scheduled and as soon as you start to get the "Object reference not set to an instance of an object." error then look at the website it just tried to renew as that will probably be the cause.

Regards

Mark Donne
https://host100.co.uk

Reply
Page 2 / 3
Share: