SolidCP no longer l...
 
Notifications
Clear all

SolidCP no longer loading after SSL Renew

5 Posts
2 Users
0 Likes
1,420 Views
InfinitM
Posts: 36
Topic starter
(@infinitm)
Trusted Member
Joined: 2 years ago

Hey Guys,

I am getting stuck with something I assume is fairly simple to resolve. I hope someone can point me in the right direction.

I installed a new wildcard SSL on our exchange servers, one of which is the main SolidCP server.
After I installed the SSL I've restarted the ISS service also, but the cp just does not load. I keep getting "ERR_CONNECTION_RESET", the strange thing is that the main domain (OWA) loads with the ssl.

It looks like it's just the port 9002 and 9001 which does not load. What may be the reason and how can I resolve it?

Topic Tags
4 Replies
InfinitM
Posts: 36
Topic starter
(@infinitm)
Trusted Member
Joined: 2 years ago

Ok so right after posting this... I thought that I might look around a bit more, and noticed I had to set the certificate that each site would use, after setting it. Problem solved. Thanks anyway 😀

Reply
InfinitM
Posts: 36
Topic starter
(@infinitm)
Trusted Member
Joined: 2 years ago

One question remains though...
How can I force an http -> https redirect with SolidCP, i've created a rule as explained here: https://aboutssl.org/iis-redirection-http-to-https/ but the site's still give a connection error on http?

Reply
Trevor Robinson
Posts: 1444
Admin
(@trobinson)
Noble Member
Joined: 7 years ago

Hello,

SolidCP doesnt have a option to force a http to https redirection. You would need to need to do it via the web.config of the site. Have you downloaded URL rewrite from https://www.iis.net/downloads/microsoft/url-rewrite onto your server?

Regards,

Trevor

Reply
1 Reply
InfinitM
(@infinitm)
Joined: 2 years ago

Trusted Member
Posts: 36

@trobinson thanks trevor. I thought it was something else D:

Reply
Share: