SolidCP WHMCS modul...
 
Notifications
Clear all

SolidCP WHMCS module v. 1.1.2 - now compatible with PHP7

27 Posts
8 Users
0 Reactions
5,459 Views
Posts: 27
(@newtothis)
Eminent Member
Joined: 7 years ago

Thanks for your reply Marco.

So I realised that I hadn't actually tried connecting from the Linux server directly and gave it a go. Here was the outcome:

[root@vps ~]# wget -p http://siteURL.com:9002
--2017-11-29 09:50:44-- http://siteURL.com:9002/
Resolving siteURL.com... ###.16.###.234, ###.230.###.128
Connecting to siteURL.com|###.16.###.234|:9002... failed: Connection refused.
Connecting to siteURL.com|###.230.###.128|:9002... failed: Connection refused.

(actual URL & IP substitutued for "siteURL.com" & ###)

So the connection is being refused even though I have the site bindings set to allow access on the port:

 

SOAP is installed and it is what is throwing the error message when it can't connect. What is blocking it on the Windows Server to make it get refused?

Reply
Posts: 80
Topic starter
(@bogdan_k)
Member
Joined: 8 years ago

Hi,

maybe a firewall issue? Are the WHMCS server and the SolidCP Enterprise Server in the same internal network? If yes, it could also be an issue with a loop, if you try to connect with the external FQDN? Maybe you can try to connect with the internal IP? This would be also my recommendation not to expose port 9002 unsecured to the internet.

You can try to enable the ICMP connection in the Windows firewall and try to ping the Win server from the Linux server. If this is successful, then it should be an issue with the IIS configuration/firewall. If it's also unsuccessful, then it's a network issue.

Best regards

Bogdan

Reply
Page 6 / 6
Share: