WSP 2.0 migration t...
Clear all

WSP 2.0 migration to SCP in an Hosted Environment

3 Posts
2 Users
0 Reactions
Posts: 2
Topic starter
New Member
Joined: 8 years ago

Hi Community,

We have upgraded this morning and encounter following error when adding i.e. a user to a hosted domain.

[12/11/2016 11:53:10 AM] ERROR: HostedSolution
System.DirectoryServices.DirectoryServicesCOMException (0x80072030): There is no such object on the server.

at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_IsContainer()
at System.DirectoryServices.DirectoryEntries.CheckIsContainer()
at System.DirectoryServices.DirectoryEntries.Add(String name, String schemaClassName)
at SolidCP.Providers.HostedSolution.ActiveDirectoryUtils.CreateUser(String path, String upn, String user, String displayName, String password, Boolean enabled)
at SolidCP.Providers.HostedSolution.OrganizationProvider.CreateUserInternal(String organizationId, String loginName, String displayName, String upn, String password, Boolean enabled)

B4 above error we found below in the event logs.

[12/11/2016 10:58:24 AM] ERROR: Could not retrieve Web Deploy key from the registry
System.NullReferenceException: Object reference not set to an instance of an object.
at SolidCP.Providers.Web.IIs60.IsMsDeployInstalled()


We checked user rights as per manual. Any hint is more then welcome.

Thanks a lot!


2 Replies
Posts: 1965
Noble Member
Joined: 9 years ago


The Web Deploy key is for when you have Web Deployment enabled in IIS Service settings (inside the solidcp portal) yet do not have Web Deployment 2.0 installed (Web Deployment is different then Web Deploy 3.5 / 3.6)

Do note that for Hosted Organization you now require Group policy management mmc and Active Directory Powershell feature enabled on your server.



Posts: 2
Topic starter
New Member
Joined: 8 years ago

Hello Marco,

Thanks for your swift reply.

Group policy management and the AD Powershell feature were already enabled before. However I'll double check the settings and get back to you.