Forum

Exchange 2016 new m...
 
Notifications
Clear all

Exchange 2016 new mailbox does not enable mapioverHttp

Page 1 / 2

Levent
Posts: 6
Topic starter
(@leventacar)
Active Member
Joined: 5 years ago

Hi,

When I create a new mailbox using exchange 2016 service; MapiOverHttp is not enabled. Outlook 2016clients cannot connect to mailbox profile when this option is not enabled, while other clients can connect using RpcOverHttp.

It might be a good to have option to enable this selection / option during mailbox plan creation.

PS: To workaround; we still can use powershell to enable MapiOverHttp for a specific mailbox.

 

Thanks,

Levent

6 Replies
Marco Tiggelaar
Posts: 1970
Admin
(@m-tiggelaar)
Contributor
Joined: 6 years ago

hmm i will check this out and report back to you shortly.

Reply
bogdan_k
Posts: 78
Moderator
(@bogdan_k)
Member
Joined: 5 years ago

I've took a look into it on our environment.

That's true, that MapiHttpEnabled has an empty value (NULL) in mailboxes on Exchange 2016. But according to the TechNet documentation ( https://technet.microsoft.com/en-us/library/bb125264(v=exchg.160).aspx) the value from the Organization will be used, if the mailbox value for MapiHttpEnabled is empty.

Can you check in the Exchange Management Shell with "Get-OrganizationConfig | format-list mapi*", which value is set globally to the organization?

Reply
Levent
Posts: 6
Topic starter
(@leventacar)
Active Member
Joined: 5 years ago

Exchange 2016 has MapioverHTTP enabled by default for organizationwide, however the behavior for mailbox to support needs to be enabled by setting MapioverHTTP to $true for the mailbox as well. By default this value is null for a new mailbox.

setting mailbox level MapioverHTTP to $true will then enable Outlook 2016 profile setup, otherwise user gets an error during profile creation. " Cannot connect exchange, server must be online etc etc""

https://technet.microsoft.com/en-us/library/mt634322(v=exchg.160).aspx article (through the end of page) has a matrix that explains how 3 values on a mailbox affects Autodiscover result..

 

My experience is ; after creating the mailbox for a user, I set MapioverHTTP value to $true by using

Set-Casmailbox <user ID or mailbox ID>-MapiHttpEnabled <parameter>

Levent

Reply
Marco Tiggelaar
Posts: 1970
Admin
(@m-tiggelaar)
Contributor
Joined: 6 years ago

Ok, just to be sure:

Your having issues connecting local outlook 2016 clients ?

(as when i connect to a outlook 2016 through external it just connects without issues with autodiscover)

Reply
Page 1 / 2
Share:
Downloads