Forum

SolidCP 1.4.7 and S...
 
Notifications
Clear all

SolidCP 1.4.7 and Simple DNS 8 Default TTL


indexebusiness
Posts: 25
Topic starter
(@indexebusiness)
Eminent Member
Joined: 5 years ago

Hi

We are using SolidCP 1.4.7 and SimpleDNS 8 with the v2 API and everything is working but we can't see where the Zone Default TTL setting is being set from.

In SimpleDNS 8 it is set to 3 hours but every zone we create using SolidCP gets set to 1 hour for all records.  The SOA and NS records are set to 3 hours but the rest are all set to 1 hour.

Is there a setting somewhere in SolidCP I am not seeing as I have looked everywhere for it.

The Service Properties screen for SimpleDNS 8 has the other settings but no Default TTL setting and I saw another post on here ( https://solidcp.com/forum/question/new-simpledns-zone-problems-after-solidcp-1-4-3-upgrade/paged/2/#post-7461) where they asked the same question and apparently it was fixed to take the default setting from SimpleDNS but ours isn't doing that.

Any ideas on where to look to change this?

Thanks

Mark Donne

Topic Tags
3 Replies
Trevor Robinson
Posts: 1303
Admin
(@trobinson)
Member
Joined: 5 years ago

Hello,

Can you check your Minimum TTL in the provider settings? This is what is set when a record is created.

Regards,

Trevor

Reply
indexebusiness
Posts: 25
Topic starter
(@indexebusiness)
Eminent Member
Joined: 5 years ago

Hi Trevor

Thank you for your reply - do you mean the service settings for Simple DNS?  If so, they are set to 3 hours as you can see here

chrome 210413 085453

Thanks

Mark

Reply
Trevor Robinson
Posts: 1303
Admin
(@trobinson)
Member
Joined: 5 years ago

Hello,

When i check the code it looks like the minimum ttl has been commented out when making a zone record so it was never added to SimpleDNS 8.x.

Would you be able to log a issue at https://github.com/FuseCP/SolidCP/issues so we can investigate the issue more. As a work around you can modify the default zone in Simple DNS -> Records -> Tools -> Default Zone Values and set the TTL here.

Kind Regards,

Trevor

Reply
Share:
Downloads